Why Do I have 1875 timing strap?


Hello I have done some playing around with MSI Armour rx 580 4gb elpida/hynix out of the box i overclocked mem to 1980 worked fine went from 560ish to 600 Hs then I decided to try mod so I copied straps 1:1500-1:1625 1:1750 1:1875 1:2000 and then 2:1500 2:1625 2:1750 2:2000 then it booted fine getting 630Hs then I try OC mem and will not go over 1895 so I reflashed trying only 2:1500-2:2000 Leaving 1:1500 -1:2000 stock no increase then I reflashed and tried only 1:1500-1:2000 it increased back to 625hs but now again I crash anything over 1900 Mem also my power draw seems to go waaaay up when I mod

Other things i tried
the new drivers -nice hash wont work
the blockchain drivers -does not work at all
the pixel patcher

things I think may be a issue
#1 win 7 64 that im using
#2 old MoBo that has only ver 1.1 pcie
#3 my timeing straps the 2:1500 2:1625 2:1750 2:1875 this i think may be a issue and 2:2000 maybe try 1625 and up???

Heres my bios

Original _MSI_Armour_4gb_GPUZ_ver.rom (256 KB)


I have the same issue with MSI RX 570 Gaming X 4GB.
elpida 1:1875/hynix not have 2:1875.
best results with modded bios 1:1500 strap until 1870MHz mem oc (1890 artifacts/pixels)
with wattman, windows 10 pro, adrenalin 18.1.1 (patched)
there is a little difference with old mobo (ddr3 vs ddr4) but is not the issue


I copied 1500-2000 yes I cannot OC mem past 1880 been running 10 days now but I will try copying only 1875 but from what you said does not seem too make much diff LOL you will laugh at this I got 2 more 8gb 580s red devil and msi v1 both micron both have 1875 strap as well so im thinking this could be something new perhaps ?


You have it, because everyone have it, for certain memory types.

What you had to do is to fire GPU-Z and determine what memory type
you actually have in your card, then play with only that type…4GB
cards usually have worse mem chips onboard, so you can’t use 1500
strap all the way up…600H/s is bad, you should have 800+
if we talk about cryptonight


what strap should be copied? I have 1875 on 4g msi elpida and 1875 on 8gb red devil micron also msi v1 8 gb micron 1875 on all 3 i copied 1750 and up on 8gb and 1500 up on 4gb i did get increases it also seems to depend on drivers and miner with one miner im getting 750hs on 4gb 820 with 8gb with claymore and 750hs 8gb 700hs on 4 gb on sgminer atm


a trick from the manufacturer is possible to allocate the gpu directly to gammers. these gpu were purchased directly from an importer, not a reseller, new a few days ago, they are now out of stock. I think the best thing in my case will be to sell them for a better price, and buy some saphire when the stock returns. I have seen that although it improves up to 1870 Mhz, in hwinfo it throws a lot of memory errors that with other strap it does not. I think msi wants to end the sale of gpu for miners


Yes they seem too crash alot you maybe correct the amd timing strap mod maybe come to an end no more modding amd cards now :frowning:


Another Idea I just had is the new drivers just came out maybe these cards will work better with new drivers?


use polaris one click (last version), solved
only download the PolarisBiosEditor.exe file
https://github.com/jaschaknack/PolarisBiosEditor (used 1.6.7 version in my case solved issue)
the copy straps dont works, polaris use better timings strap they dont in the original vBIOS
if you get 0 errors and good hashrates well can tip me eth:
ps: dont oc too much! :slight_smile: dont need with good drivers, good mining!