SAPPHIRE RX 580 Nitro+ 8GB - Hynix


I also have this problem when trying to flash any rom from another site but it will accept the roms i backed up.


Can someone post this BIOS?

Here is the stock version I have:

sapphire-rx580-nitro-miner03-gpu3-stock.rom (256 KB)


Hi, I also have an error on programming a modded rom, so may be You can assist, what timing should be changed.
Card is saphire RX580 nitro+ with Hynix memory.
I also noted that timing straps refers to i.e. 1:2000 and 2:2000, so, should i change it in both places or just 1:2000.
Im new to this.

Eth rate is just 20mh, with -dcri i’ve got 21.

thanks in advance.


I found this Strap for 1750, 2000 and 2250 on Ethereum Forums. I can reach ETH 30MH/s (Dual mining Sia) on EthOS so I expect some room for improving it on Windows:
I think this Strap can be yet optimized (I read it comes from the 1750 strap for a Micron Memory).
I hope it helps!


Hi Anorak, awesome stuff with your forum layout. I just signed up. Can you confirm that the above download is the latest ROM for my Sapphire RX 580 Nitro+ 8gb Hynix cards?


how to fix it? Cannot erase ROM


I have this same problem. Can someone please help? I’ll link my bios below.
sapphire-rx580-nitro-stock.rom (256 KB)


I have same problem :frowning:


Check the size of your ROM - 256k or 512k, it has to be matched. If you tried to mod using 512k to replace 256k rom bios, it will give this error msg.


send it to my email too please thank you


I have the same problem - mine VBIOS is 256kb, so can you send it to



So I’ve got the Sapphire Nitro+ RX580 8GB and I’ve been attempting to increase the hashrate via combination of OC settings and bios mods. The OC settings are working great, but the bios mods are not. I haven’t bricked my card yet but I’m not afraid of it seeing as how I can restore it, but it doesn’t seem to change the hashrate at all. Yes i have checked to see if the bios switch is flipped on the card itself. Yes i have applied the patcher. Yes i have tried flashing using both the application ATIflash and using it in command lines. No I am not greeted by any error messages at any time during this process and furthermore, after I have installed the modded bios to the card, i reboot and save a copy of the bios now on the card to read it and make sure my modded version has actually been installed to the card. It has been and i have also used several other people’s ROM’s thinking that maybe the ROM that I made was faulty somehow but even with theirs i still get 0 difference in hashrate. This seemingly doesn’t make any sense. If anybody has any advice I’d appreciate it! Thanks

EDIT: forgot to add that this is in fact Hynix memory


I’m trying to mod but with no luck, my bios is 256kb, kindly please send a stable moded bios to

Thank you.


I can help, add me on skype: bijac666 or my fb page:

You should get 31-32 MH/s ethereum and 920 MH/s decred on windows. Cards should be at 55C at 30-40% fan speed and a rig of 6 of those cards should use 850W (gpuz will show 95W per card).
I can help you get exact those results in windows :slight_smile:


Please contact me at to my bios of a Sapphire rx580 8GB Hynix


Has anyone got the 256KB version rom of this card? 30+ hashrate? Please help.

Problem with new RIG, Sapphire rx580 Nitro+ 8gB Hynix

I don’t know if everyone got the hashrate they wanted but if not, consider trying this BIOS: Sapphire Nitro RX 580 8GB (Hynix) Modded Undervolt 950mV mclock cclock BIOS.rom (256 KB) I used it on more than one mining rig and each GPU got at least 31 MH/s.The memory clock speed and the core clock speed are hard coded inside the bios (2200 and 1250). It’s also already undervolted. My 6 GPU mining rig draws 950-960w from the wall when the monitor is turned off. Hope this helps someone!

Vbios Request for Sapphire RX 580 8GB with Hynix
Sapphire Nitro+ (Nitro Plus) RX 580 8GB 512KB BIOS for power saving
GPU-Z Bricked Two New 580 Nitro+ 8GB Hynix Cards!

Hi BeardEnthusiast,

I try to my Nitro and i got 28

I am having the latest drivers of AMD 22.19.676.0 released 5 SEP 2017

any suggestion ?


Try using AMD’s driver dedicated for blockchain compute:
Try that and let me know if your hashrate has gone up! Uninstall your current driver using DDU (Driver Display Uninstaller) in safe mode, then install the driver you downloaded from the link. Don’t forget to use ATI Pixel Clock Patcher after you installed the drivers.

Vbios Request for Sapphire RX 580 8GB with Hynix

I just tested this BIOS and I get amazing results. Before I had 29mh/s for eth and now 31mh/s (single mining). Also the power consumption dropped a lot. Long story short: before, I was dual mining and I was getting 170mh/s eth and 6200mh/s decred and 1500wh (6 x 580 nitro+ rig). Now I have 178mh/s eth, 6600mh/s decred and 1250wh…which is a huge improvement.
Please note that I have uninstalled the previous driver and installed the one for blockchain.

Thanks a lot, I hope that people with Radeon RX 580 Nitro+ (also Special Edition/Limited Edition) will find this thread!
Best regards