Sapphire RX 470 4gb Nitro OC Hynix(No +)


#1

I hereby request a VBIOS rom for the following graphics card.

Brand: Sapphire
Model: RX 470 Nitro(non +)
Memory size: 4GB
Memory manufacturer: Hynix
Custom settings: Memshift

Sidenotes: For eth mining(hopefully at the 29mh+ which doesn’t produce too much heat).
This is a single bios rx 470 sapphire, i am worried if i did hex editting i might cause some issues that could not be fixed.

saved from gpuz original
hynix_sap_470_ori_gpuz.rom (256 KB)

Saved from atiwinflash original
Saph470-4gb-Elpina-STOCK.rom (512 KB)

Tried to flash with this
Anoraks_Sapphire RX470 Nitro OC 4GB Hynix_memshift.rom (512 KB)

How the original looks like in polaris editor

This is the error i am getting for flashing Anoraks_Sapphire RX470 Nitro OC 4GB Hynix_memshift.rom


#2

You used the wrong rom.
The one you tried to flash is for Hynix memory. But your card has a Elpida memory. :slight_smile:

Oh and the rom from me is for the Nitro+
Watch out for the titles to all downloads. :slight_smile:


#3

Here is a new set of roms based on your backup. :slight_smile:

Sapphire RX470 Nitro(non+) 4GB Elpida
Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_memshift.rom (512 KB)
Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_overclock.rom (512 KB)
Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_powersave.rom (512 KB)
Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_original.rom (512 KB)


#4

its weird gpuz is showing hynix, if i flash the elpida rom, would i still be able to revert back to the original if there were any issues


#5

You would brick the card by flashing it. As the non + does not have a dual vbios, it is hard to revocer the card actually.


#6

alright, thanks anorak!!, i will stay away from single bios :wink:


#7

Hello Anorak,
do you have memshift bios for Sapphire RX470 Nitro OC 4GB Hynix (Non +)?

My GPUZ show Hynix memory and when I load orginal bios in Polaris editor, I have timing values like on Netballz picture.

My bios lock like this:

Thanks a lot.


#8

I made some roms for you based on the roms you have uploaded. :slight_smile:


#9

Hi i have use both of the rom 1 of it is the undervolt one and it seem running around 25m/h and when i use the overcloak one is running 28.5 m/h but the problem is when running only eth so far is stable but when i dual mine with drc it will shut down i not sure what the problem … i m gonna try using the undervolt one and see dual mine how it goes … cause 25++ is abit low but i forget to check how much is the Watt from the wall
so far running from the overcloak one is running somewhere 1200watt if dual mine … and 960wat if single mine i m running 1500watt dual psu so not sure what is the problem


#10

The gpu might get instable due to the extra load produced by DCR.
I only run in ETH mode.


#11

Hi Anorak, I having a resolution issue after used the Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_memshift.rom.

Any solution to revert back to the default resolution?

Thankyou.


#12

If I’m not mistaken… that happens after reboot with no screen connected. If you connect a screen do you still have this issue?

Some motherboards have a default resolution setting in their BIOS which you can change.


#13

Connect with the monitor doesn’t had this issue, it only happen while i remote it. Thanks for your answer :slight_smile:


#14

Correct answers. :slight_smile:

Without a connected screen or at least a hdmi/dvi dummy plug the resolution is stuck to 640x480.


Optimizing RX 470 4gb nitro(non+)
#15

Hey, I have RX 470 4gb Nitro (non+) with Hynix memory. And I have same picture as here Sapphire RX 470 4gb Nitro OC Hynix(No +)

Can you please mod my BIOS.

Saph470-4gb-Elpina-STOCK.rom (512 KB)

UPD: Wow! Why the forum changed tittle of my uploaded file? It was “Sapphire-rx-470-4gb-nitro-nonplus-hynix.rom” GPU-Z tells me that I have Hynix. Is it a bug at a GPU-Z and really I have an Elpida?

UPD2: 5adfc02fdd48eb39cdf134b402ffdd69 *Sapphire-rx-470-4gb-nitro-nonplus-hynix.rom MD5
Sapphire-rx-470-4gb-nitro-nonplus-hynix.rom 1451F03B CRC32
a3cea8b274e65028828d1dd782ca1965614e4aeef37bedbb85561ee70a3365d2 *Sapphire-rx-470-4gb-nitro-nonplus-hynix.rom SHA256

UPD3: I really read the thread. Seems like that (non +) bioses from Anorak with “Elpida” inside the name are what I need. I flashed that bios and got from 26.5 to 29.2. But GPU-Z still tells me that I have a Hynix.

So for everyone, who have the same issue: This “Elpida” bioses works fine with 470/4 (non+) “Hynix’es”.


#16

Hi Anorak

i am interested too in this BIOS for Hynix memory and i have the same problem, i can not see timmings correct. what can i do?

Regards


#17

with gpu-z showing hynix, you flashed the Anoraks_Sapphire RX470 Nitro(non +) 4GB Elpida_memshift.rom rom?
and it worked accordingly? Thanks for the confirmation i will try to flash one card aftewards :slight_smile:

i tried to upload xxx.rom but it shows Saph470-4gb-Elpina-STOCK.rom as well. the forum changed my upload filename as well.


#18

@usa:
The filename got changed because this file was uploaded earlier. The forum does check the signature of every uploaded file and as long as the files are identical, the name will be the one of the very first uploaded file.

There are roms that do include timings for Hynix AND Elpida at the same time.

So you can flash that very vbios onto a Hynix or Elpida card.


Sapphire RX 470 Nitro (no +) 4G Hynix SKU 11256-10-20G powersaving
#19

I updated the files accordingly.

Sapphire RX470 Nitro(none+) 4GB Hynix+Elpida
Anoraks_Sapphire RX 470Nitro(non +) 4GB Hynix Elpida_memshift.rom (512 KB)
Anoraks_Sapphire RX 470Nitro(non +) 4GB Hynix Elpida_overclock.rom (512 KB)
Anoraks_Sapphire RX 470Nitro(non +) 4GB Hynix Elpida_original.rom (512 KB)
Anoraks_Sapphire RX 470Nitro(non +) 4GB Hynix Elpida_powersave.rom (512 KB)


#20

Anorak, thank you so much for your roms!!