Poor hash rate Asus RX 570 Strix OC


I have really poor hash rate from this card. I can’t get more than 12 MH/sec. When I look with Asus GPU tweak. it reports 100% usage of the card. If i use MSI Afterburner it reports 2 cores on the card as GPU1 and GPU2. I have GPU1 running at 100% and GPU2 is idling? wtf? I included screen shots
Stock Bios
Tried the bios from here. same results



at stock i’m getting about 16mhs after i did a clean installation and change to compute i got 18mhs, mess around with MSI After burner running on 1350/2080 with power draw -5%, now it’s stable at 23.6mhs. I’m not able to flash any other mods, and still waiting for people to point what i did wrong.


Hi muteddisk,

Have you tried using Claymore Miner? I had a similar issue and just by switching to Claymore added about 20% to the Hash Rate. I also uninstalled the latest Drivers using DDU and then installed AMD Blockchain drivers added another 2MH/s on Ethereum. Know this doesn’t 100% solve the issue, but might get you closer to 20MH/s.

Also struggling my **** of with my RX570s, but these small wins ,make a difference.

Good luck bro!


I’m seeing 17Mh/s ETH using Claymore, Windows 10 Pro. I used a Polaris “one-click” Bios Flash and got it to 19.x MH/s. Online I’m seeing people get over 20… what’s up with that?

My BIOS doesn’t look like any I’ve seen out there, and I’m not using Afterburner or anything like that.

Also, CPUID HWMonitor is showing: 102W and 69C temp.

Anyone want to chime in?

I can provide screenshots or stock BIOS to any experts out there.

Alex V.


blockchain driver were crashing with claymore. now running with ethminer at 22.4 MH/s. definetly something is wrong with minergate. I tried a r9 270x at minergate add trouble passing 150 H/sec with cryptonote. tried with claymore cryptonote and I get 487 H/sec. thanks for the suggestion.


I have mine clock at gpu 1440 MHz and memory at 2050MHz. I get 22.4 with ethminer. Modded bios no power save at 130w


is your Asus RX 570 Strix OC 4Gb or 8Gb?

im running claymore on Asus RX 570 Strix OC 4Gb and my hashrate is 24.75Mh/s Hynux Memory with this settings after my email:

-epsw x -mode 1 -ftime 10 -mport -3333 -tt 60 -fanmax 80 -cvddc 1050 -mvddc 1050 -cclock 1250 -mclock 2150,2150,2150,2150,2150

refer to this topic to find your latest mod.(i believe the mod i used is on page 3 and i also used the patcher and restarted the rig after patched)


patcher… you mean the ATI driver patcher?


I actually didn’t use your bios. it was making the card get hot…like 65 C. I put back my old modded bios and clocked back to 1425 gpu and 2000 on the ram.
this my switches. I didn’t use yours to set the speed and vCore. I didn’t like it on my card. Trying to over clock your bios was not getting me more then 20MH

here my bios and I get 22.5MH with clocks above.

Asus RX 570 ROG Strix OC 4GB 256kb bios

Claymore eth+decred version 10.4 switches

-allpools 1 -ftime 10 -mport -3333 -tt 60 -fanmax 100