MSI RX 580 Armor OC 8GB Hynix


#11

There you are. Fresh VBIOS with new timings.

My settings: 0,983V , 1200 / 2120 MHz

Hashrate is: 29,6 MH/s

Tweak it more if you can, the timings are copied to 1:1750 and 1:2000 and 2:1750 and 2:2000. I believe they are from XFX Hynix 8GB GPU.
2_apolyon_msi580_hynix.rom (512 KB)


Edit 1: The best and stable settings tested on 12 GPUs (2 seperate rigs with same MSI Armor 8g OC Hynix):

  1. Claymore Miner 9.5
  2. In your .bat file at the end of line add -cvddc 900 -cclock 1200 -mclock 2080 = 29,3 MH/s per card.

On Linux you could get better results, on SMOS I’ve got like 29,8-30 MH/s but power draw was slighly higher and I stay on Windows for that purpose.


Edit 2: Many people asking me about my ETH address so if you’re willing to make a small donation my ETH wallet is: 0x885972d6b2c6e1992315b81abb151c2217460bd9


#12

This one really helps. Thanks a lot.
BTW, I have tried this VBios already, copying 1:1750 to 1:2000 and 2:1750 to 2:2000.
Maybe I am not as good as you tweaking the clock. :disappointed:

Here comes a problem.
I have 3 cards with hynix memory, and only one of them’s clock can be modify by " -cvddc 983 -cclock 1200 -mclock 2120 ".
Even if I delete " -cvddc 983 -cclock 1200 -mclock 2120 " in the start.bat file, that one still operate under 983mV cc 1200 mc 2120.
The other two always operate under default clock speed. These two can be modify by afterburner, though.
All of them get 28.3Mh/s, stable.


#13

Thank you so much. I’m running it stable at 29.5MH, didn’t think it was possible to get it that high. You sir are a Legend. :thumbsup:


#14

Thank you so much @Apolyon I’m testing core 1200 mem 2000 and hashrate : 28 Mh/s without memory errors.


#15

Hey Shadow,

did you use apolyon’s rom that he posted?

I have the same MSI RX 580 8GB Hynix memory.
i have 1: and 2:, my 2: timings go up to 2:2250

Kind regards,
Edward.


#16

Thank you , this worked perfect for me… MSI Radeon RX 580 DirectX 12 RX 580 ARMOR 8G OC


#17

Hi, thanks for the rom. It reached around 29.5 mh/s but not stable. For whatever reason pc rebooted after a few hours. I am now trying 1200/2120. also, these settings seem to work well on windows but on linux the best I can get is about 26.7 mh/s


#18

New to mining and was able to get this version GPU. I overclocked and set the VBIOS to @Apolyon settings (Thanks for sharing). 1200 / 2120 MHz. However, I am only getting ~27MH/s. I am using daggerhash from Nicehash on an unactivated Windows 10 setup.

Any thoughts on why I can’t push it to 29?


#19

Hello, I am using the same bios mod by @Apolyon and I get the same! I have 8GB version!


#20

So I switched to claymore miner and I am getting 29.8 MH/s! Thanks again for the Bios @Apolyon


#21

You’re welcome @PlantDr

For anybody who have problems I should have mentioned it at the beggining - I was using for testing purpose the Claymore Miner - dunno how it will work with other miners.

If you have any problems with this BIOS try lowering the mem clock - mem errors would cause your GPU unstable.

I reached stable 900 mV 1210 core clock 2080 mem clock stable with second rig with this GPUs and it’s about 800 Watts solo ETH mining @ 176 MH/s (29.33 MH/s per GPU). Same setting brought me to 1000 Watts @ 176 MH/s ETH and 3400 MH/s SIA.


#22

Have the same card. There are no 2200 straps in it. Why?
Anyone could get close to 30 Mh/s on this card? Please help!


#23

Thank you, this worked on MSI Radeon RX 580 ARMOR 8G OC Hynix Windows 10 Crimson Edition 17.4.4
22MH/s Stock at to 29.8 MH/S Modded bios APOLYON MSI afterburner 0,983V 1200Mhz 2120 MHz Very Stable 3 days work no error no reboot.
My rig is 4 Cards at 118MH/s on Calymore Miner v9.5 780 Watts
Sorry, my English I am a French.

Thank you APOLYON.


#24

Has anyone else had their Armor card starting to perform better? I still in a test rig, before I get my actual rig set up and my MSI Armor normally pulled 100W at 69 degrees, but for some reason it is now pulling 86W and is at 66 degrees and I haven’t changed anything. I’ve only restarted my miner a couple times due to me rebooting my computer a couple times for other reasons.


#25

So my MSI is acting up now. I was running it with a RX 580 Red Dragon for 2 days and they were both working fine. Today I restarted my computer and my MSI is hashing at 4 MH/s when the Red Dragon is also working. If I just use the MSI it hashes at 29.5 MH/s, but my computer is pretty laggy (didn’t happen before) and evertime I try to fine tune the overclock it sounds like the fan shuts off and my screen flickers dark green for a bit and then the GPU continues. Is the a sign that my GPU is about to crash or is faulty?


#26

Thank you! My two 580’s were doing 22mh stock. Now they are both doing 27.8! Total rig hashrate went from 70 to 80 on my three card rig. Very happy.

Recommend to anyone with 580 Armor 8gb with Hynix memory.


#27

Hi Guys. First post. I’m gonna try the bios you provided Apolyon. (the destroyer… lol hope not). If it works then your my hero.


#28

Hi Friends,

May I have the powersave version of this BIOS for Hynix RAM so I can use it in Linux? Thank you in advance.


#29

Vbios did not work. Graphics card was disabled due to errors in Windows.
Doing the straps in the original vbios from 1750 to 2000 also did not work. I can’t seem to push it beyond 25 MHs.


#30

@Raziel, probably you are doing something wrong. Are you sure you have Hynix memory? Could you post your screenshot from GPU-Z? I tested this bios “2_apolyon_msi580_hynix.rom” and it works for me just fine with 28+.