MSI Radeon RX 570 ARMOR 4G OC


#362

This card needs a BIOS hotfix, there’s something fundamentally wrong with it on mining (it works great with gaming/etc).

I can get to 85w (on GPU-z) on pretty much any other card but this one, I’ve been using this with 1150/2100 (30 MH/S) but this one can’t go above 1100/1900 while using 100w at 27 MH/S. I’ve managed to get this one to 31 MH/s which is pretty good but the power consumption was 140w.

I have tried undervolting this card but it would just crash at less than 900mv while getting about high 130s.

What I know so far: This card comes “overclocked” if there was a bios who reversed the factory OC and made it so it works as a regular card, the power consumption would go away with good hashrates.

I have tried Elpida’s XFX RX 570s power save rom and it had very very low consumption on this card but it wouldn’t go above 20 MH/s.

Shared all I know, maybe someone can take it over from here as far as I know.


#363

@MrCryptoMan wattage? I’ve done this too.


#364

IMPORTANT Just came here to say this DO NOT download mrCryptoman mod files the ATIFLASH is a crypto miner Trojan and backdoor scan it with malware bytes you will see, ban this ggugy please


#365

What memory is this brother?


#366

Where are the SAMSUNG bios’s? I could really use one! Anyone?


#367

You ever find out what memory that was for? Do you have a rom for Samsung MSI Rx570 ARMOR OC 4GB?


#368

this is only for hynix? not for elpidia?


#369

The overclock.rom made my elpida card not recognizeable. Had to revert.


#370

any definitive 5E2 bios around? I flashed one and now am having troubles at boot… even if I use E1 powersave from Anorak… any conservative E2 bios so I can at least boot 3 cards with one PSU? (they booted before)


#371

Good day, I’ve tried flashing the all the VBIOS here in AtiFlash but it says Subsystem ID mismatch. Please help. Thanks. :slight_smile:


#372

I have a 7 card rig drawing 880watt from wall
4x rog strix and 3x armor cards…
Hashing with 207 mhs.

So 110watt for 1 card is actually quite good when hashing with 30 mhs !

My friend has 7 card rig with sapphire nitro’s and he is pulling 950watt… and he is hashing with 210 mhs


#373

my 110 was from the GPU-Z, not from the wall calculation. from the wall it’s probably around 140-150.

But that is low from the wall at 880 watts, my 7 card rig was puling 980 from the wall and pushing the same hashrate as you. But my rig is a frankenstein of armor, red dragons, gaming X, XFX and ROG strix.

That’s strange on your friend’s nitro+, my nitros definitely run at lower wattage (not by much) with bios mods. Though definitively not worth the additional price per card.

With the new Phoenix and claymore miners, the differences in hash rates are starting to tighten up. my MSI cards are all above 30 now with my sapphires running at 32.


#374

You’re a life saver. Thanks for taking the time to post this, saved me a lot of time looking for this exact rom.


#375

Hi, here it is biosMSI Radeon RX570 ARMOR 4G 30+Mhs

MSIRX570ARMOR29 Mhs.zip (3.5 MB)


#376

original rom or not ?


#377

1150 2100 Core voltage -100 (-cvddc 900)
MSIRX570ARMOR29 Mhs.zip
30.5


#378

Here it is mod bios MSI Radeon RX570 4G ARMOR 30.7Mhs
atikmdag-patcher
ATIFlash

MSIRX570ARMOR307Mhs.zip (3.5 MB)


#379

1268 core clock and 65288 mV core ?! its 180w almost TDP . LOL
2 of my 25 rigs are with 570 msi 4G , Hynix + Elpida , they run at 28.6 mhs , 0 errors and 52ºC and 124w TDP .


#380

Also what you posted contains shitty timmings of PBE 1.7.1 .


#381

Here is your sh!t bios :smiley: 1 gpu is yours and 2nd is mine .

Yours more than 61ºC Mine is @ 52-54ºC
Yours 119w TDP Mine 94w TDP
Yours 24,8 mh/s Mine 28.4 mhs , so please , stop posting kk bios without experience in this domain :smiley: